Bienvenue sur le forum de la Communauté EzCom !

En ces lieux, nous vous aidons à mettre en place et à personnaliser votre forum phpBB 3.1.x, 3.2.x, 3.3.x & 4.0.x grâce à :

Une fois inscrit.e, vous pouvez :

Dernières nouvelles :

Coup d’œil : « EzCom Blog » idéal pour trouver des conseils et des services pour son forum phpBB !

Soutenir le projet de la Communauté EzCom.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

Welcome on the Ezcom Community board! | English visitors, may I help you? Image | Make a donation to EzCom.

MISE EN PLACE : d’un forum de tests copie du forum en production  Question traitée

Comment procéder à des tests pour son forum sur un second forum copie conforme de l’original | How to proceed some tests on a copy phpBB board.

Assistance & documentations pour phpBB et son environnement.

Modérateurs : Graphistes, Traducteurs

Avatar de l’utilisateur
hamidouki-dz
EzComien
EzComien
Messages : 174
Enregistré le : dim. 27 sept. 2015 23:55

MISE EN PLACE : d’un forum de tests copie du forum en production

Messagepar hamidouki-dz » mar. 29 mai 2018 23:19

bonsoir
j'ai installer un sous domaine sur mon domaine et chaqu'un a ça propre base de donnée pour faire des testes sur le sous domaine par exemple:
http://www.techniarabia.com et http://www.techniarabia.com/medianav/
alors est ce que c'est possible de copier les membres avec leurs propre mot de passe ?
comment faire un pont entre ces deux forum
le sous domaine est faite juste pour les extensions que je les testes vu que je ne veut pas les testés en local et pour éviter les bugs et les problèmes que ça m'arrive sur mon forum en production /root chaque fois je serai obliger de restaurer mon forum a une date précédente..
merci pour les réponses d'avances et pour d'autre proposition si c'est le cas .
salutation

Forum maintenance industrielle
Communauté maintenance industrielle

Contenu publicitaire :

Avatar de l’utilisateur
Raphaël
Chef de projets
Chef de projets
Messages : 2996
Enregistré le : ven. 24 oct. 2014 18:02
Localisation : Marseille

MISE EN PLACE : d’un forum de tests copie du forum en production  Question traitée

Messagepar Raphaël » jeu. 31 mai 2018 05:53

Un sous-domaine correspond à ce qui se trouve avant le domaine, exemple : http://git.ezcom-fr.comgit est le sous-domaine de ezcom-fr.com.

D’ailleurs à ce propos www est en fait un sous-domaine lui aussi ! Exemple : http://www.domain.tld souvent utilisé comme adresse par défaut (d’accueil) des sites Web. ;)

À contrario, si je prends ton exemple : http://www.techniarabia.com/medianav//medianav/ n’est qu’un sous-répertoire du répertoire racine, pas un sous-domaine. ;)

Bon sinon, pour te répondre, pour disposer d’un forum de test, le mieux est de dupliquer ton forum en production et de placer ta copie exacte (fichiers) dans ton sous-répertoire /medianav. Copncernant la base de données il faut en faire une copie et l’importer dans une seconde base de données créé pour l’occasion. C’est la méthode la plus simple et efficace pour tester des outils. La seule chose à modifier sont les informations dans le fichier /medianav/config.php à faire correspondre avec la seconde base de données du forum de tests puis de vider le répertoire /medianav/cache/ pour éviter tout conflit.

Aussi, pense à renseigner dans ton fichier « robots.txt », tel que : http://www.techniarabia.com/robots.txt de ne pas indexer le répertoire /medianav sinon Google va indexer ton forum de test (copie de l’original) et tu risquerais d’avoir du « duplicate content ».

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

🔍 Recherches :
Questions : ✚ Extensions présentées 🎨 Styles présentés ★ Toutes autres questions

📖 Documentations :
✍ Traductions : Demander Proposer

Avatar de l’utilisateur
hamidouki-dz
EzComien
EzComien
Messages : 174
Enregistré le : dim. 27 sept. 2015 23:55

MISE EN PLACE : d’un forum de tests copie du forum en production

Messagepar hamidouki-dz » sam. 2 juin 2018 23:34

salut
est ce que je ne rencontrera pas un conflit de membres dans la base de donnée ?
et pour indexation , je doit que supprimer le lien qui va montré le chemin aux répertoire /medianav/ !
merci

Forum maintenance industrielle
Communauté maintenance industrielle

Avatar de l’utilisateur
Raphaël
Chef de projets
Chef de projets
Messages : 2996
Enregistré le : ven. 24 oct. 2014 18:02
Localisation : Marseille

MISE EN PLACE : d’un forum de tests copie du forum en production

Messagepar Raphaël » dim. 3 juin 2018 02:37

hamidouki-dz a écrit :Source du message est ce que je ne rencontrera pas un conflit de membres dans la base de donnée ?

Non puisque tu auras deux bases de données.
hamidouki-dz a écrit :Source du message et pour indexation , je doit que supprimer le lien qui va montré le chemin aux répertoire /medianav/ !

Tu mets ceci dans ton fichier robots.txt :

Code : Tout sélectionner

User-agent: *
Disallow: /medianav/

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

🔍 Recherches :
Questions : ✚ Extensions présentées 🎨 Styles présentés ★ Toutes autres questions

📖 Documentations :
✍ Traductions : Demander Proposer

Avatar de l’utilisateur
hamidouki-dz
EzComien
EzComien
Messages : 174
Enregistré le : dim. 27 sept. 2015 23:55

MISE EN PLACE : d’un forum de tests copie du forum en production

Messagepar hamidouki-dz » dim. 3 juin 2018 04:41

merci pour tous ces information , j'apprend chaque jour grâce a vous ;)

Forum maintenance industrielle
Communauté maintenance industrielle

Contenu publicitaire :


Retourner vers « Support pour phpBB »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité